Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Resolved

Performance has returned to normal following containment of the high-volume background activity affecting shared platform resources.

The containment was successful, and we have confirmed that services are operating normally. We will continue monitoring the environment for any recurrence or further impact.
Posted Sep 14, 2026 - 01:36 PDT

Monitoring

We have identified the likely root cause as a high-volume background processing activity that placed sustained demand on shared resources within our multi-tenant environment.

The activity has been contained, and system performance has improved. We are continuing to monitor the remaining processing backlog as it clears. Temporary CPU spikes may occur while queued work is completed, but these spikes are intermittent and are not currently resulting in sustained service degradation.
Posted Sep 14, 2026 - 01:04 PDT

Investigating

System monitors are currently showing higher than usual response times, but no errors. We are currently working on restoring normal system behavior. We will update this page once root cause is determined.
Posted Sep 14, 2026 - 00:16 PDT
This incident affected: PEAK 15 Systems (PEAK 15 Systems Application and Iframes).