Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 14:19 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 11:33 PST

Update

We experienced intermittent connectivity issues caused by limitations in outbound network capacity within our hosting environment. The issue has been resolved, and we have implemented architectural improvements to ensure increased stability and prevent similar disruptions in the future. We will continue to monitor for system stability.
Posted Mar 03, 2026 - 11:10 PST

Investigating

We are currently experiencing intermittent issues with Planner 2.0. Our team is actively working to resolve the problem and appreciates your patience.
Posted Mar 03, 2026 - 08:54 PST