Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Resolved

We experienced a brief interruption (less than 5 minutes) affecting a subset of authentication requests. Services returned to normal quickly, and we restarted related services as a precaution. All systems are currently operating normally.
Posted Mar 13, 2026 - 22:31 PDT

Investigating

System monitors are currently showing higher than usual response times, but no errors. We are currently working on restoring normal system behavior. We will update this page once root cause is determined.
Posted Mar 13, 2026 - 22:06 PDT