Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Resolved

The system has worked through all background processes and system health is back to normal.
Posted Feb 04, 2026 - 16:46 PST

Update

We have identified the cause of today’s performance degradation as an unusually large background processing job that triggered a high volume of system activity. To fully restore system performance and stability, we will be performing a brief maintenance restart of part of our infrastructure.

During this time, users may experience a short service interruption. We expect this maintenance window to be brief and will continue to monitor closely as systems return to normal operation.

Thank you for your patience while we complete this work to ensure continued reliability.
Posted Feb 04, 2026 - 14:41 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 04, 2026 - 14:03 PST

Investigating

System monitors are currently showing higher than usual response times, but no errors. We are currently working on restoring normal system behavior. We will update this page once root cause is determined.
Posted Feb 04, 2026 - 11:20 PST