Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Resolved

Beacon is back to operating normally.
Posted Mar 04, 2026 - 12:07 PST

Identified

System monitors are currently showing higher than usual response times, but no errors with Beacon. We are currently working on restoring normal system behavior. We will update this page once root cause is determined.
Posted Mar 04, 2026 - 11:28 PST
This incident affected: PEAK 15 Systems (Beacon and Webforms).