Verification is currently underway for the maintenance items.
Posted Mar 15, 2025 - 08:55 PDT
Update
Starting final group.
Posted Mar 14, 2025 - 18:00 PDT
Update
Starting Eastern groups
Posted Mar 14, 2025 - 15:00 PDT
Update
Starting Europe group.
Posted Mar 14, 2025 - 13:18 PDT
Update
We are running a little behind on starting Europe group. We will begin shortly.
Posted Mar 14, 2025 - 13:11 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 14, 2025 - 12:00 PDT
Update
Starting Asia group in 7.
Posted Mar 14, 2025 - 11:53 PDT
Scheduled
Please note the following times for deployment:
Asia / Australia: Start: Mar. 14th @ 12pm Pacific
Europe: Start: Mar. 14th @ 1pm Pacific
Americas (East): Start: Mar. 14th @ 3pm Pacific
Americas (Pacific / Central / Mountain): Start: Mar. 14th @ 6pm Pacific
This event window will close on Mar. 15th @ 12pm Pacific.
During this time, the system will remain largely operational but please keep in mind that performance may be impacted. We will be working to deploy the release as smoothly as possible and appreciate your patience. Please subscribe to this status page for future updates.