Verification is currently underway for the maintenance items.
Posted Apr 15, 2025 - 12:09 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 15, 2025 - 10:20 PDT
Scheduled
We are not expecting any outages during this deployment. Please be advised that performance may be slightly impacted as we move through the maintenance window. We thank you for your continued patience as our team works diligently to deploy the fix.