Yellow - Performance Degradation

Incident Report for PEAK 15 Systems

Update

Performance appears stable. We will continue to monitor throughout the night.
Posted Sep 14, 2026 - 02:28 PDT

Monitoring

We have restarted the services showing signs of degradation, and performance has returned to normal. We are monitoring the environment to confirm continued stability.
Posted Sep 14, 2026 - 02:18 PDT

Investigating

We are experiencing further intermittent slowness currently affecting Dynamics. This appears to be secondary performance issue resulting from the high-volume background activity identified in the original incident. While the original activity has been contained and CPU utilization has improved, the resulting impact on the shared environment has not fully cleared.

We are continuing to monitor and investigate the secondary issue and will provide further updates as recovery progresses.
Posted Sep 14, 2026 - 02:11 PDT